Dr. Eugene Spafford claimed to Congress that the PSN server software was outdated, but some community investigation has showed that to not be the case.

Last week, the House Subcommittee on Commerce, Manufacturing and Trade heard testimony from Dr. Eugene Spafford of Purdue University that the server software PSN was running on was outdated, and that this may have contributed to the recent security breach. Today, it has emerged that Sony was, in fact, running the latest version of Apache and not an outdated copy at all.

Spafford said outright that he had "no information about what protections [Sony] had in place, although some news reports indicate that [it] was running software that was badly out of date and had been warned about that risk."

A member of the Beyond3D forum, a community of technologically-minded users, decided to investigate using Google's webcache system. According to a page request archived on March 23, 2011, Sony was running version 2.2.17 of the Apache server software, which is the latest stable version available today. This repudiates Spafford's claims, which were second hand in the first place and may well have stemmed from nothing more than Internet rumors and IRC chatlogs anyway.

You can find out more about Beyond3D community member "deathindustrial"'s investigation here.