Apple yesterday released an update for AirPort Extreme, its wireless networking product. The company this was to improve compatibility with its base stations and networks and fix a security bug.

The update also improves compatibility for the MacBook Core 2 Duo and the MacBook Pro Core 2 Duo when using certain third-party access points configured to use WEP Open System security.

The AirPort update includes a fix for a security issue where attackers on the wireless network may cause system crashes. A security note on Apple's website says that an attacker in local proximity may be able to trigger a system crash by sending a maliciously crafted frame to an affected system.

This security issue affects the Core Duo version of Mac mini, MacBook, and MacBook Pro computers equipped with wireless. Other systems, including the Core 2 Duo versions, are not affected.